Ознакомьтесь с нашей политикой обработки персональных данных
  • ↓
  • ↑
  • ⇑
 
21:15 

ЭВМ ли телефон? Нет?

Настоящий дворянин и программист
У товарищей тут телефон НЕ ЭВМ. А, что! Это идея! Несколько андроидофонов в кластер на линупсе и 1С можно не покупать! Раз телефон не ЭВМ, то и 1С не ПО. Какая-такая лицензия?







Особо юморных товарищей от комментариев, вроде "1С и так не ПО" прошу воздержаться.

@темы: забавное

00:12 

Интервью с Андреем Данилюком

Настоящий дворянин и программист
Мой коллега, Андрей Данилюк, недавно давал интервью для одного любопытного блога.

Полюбопытствуйте редкий пока для "наших кругов" формат.

@темы: забавное

15:53 

Настоящий дворянин и программист

Функция Wolf() в полнолуние void на луну!

(c) баш

@темы: башорг, хумор

15:38 

MVVM, 1С

Настоящий дворянин и программист
Luxoft наконец-то выложил видео с семинара про MVVM, о котором я как-то писал.








Все-таки между схемой "Модель-Вид-Модель вида" и схемой "Объект-Форма-Структура данных формы" есть что-то общее. Можно сказать, что в режиме управляемого приложения, платформа 1С вынуждает разработчика использовать MVVM.

И глядя на вопрос с этой стороны некоторые загадочные моменты становятся более понятными. Например, функция "РеквизитФормыВЗначение" реализует доступ к данным модели вида. И вообще все операции, которые делаются между объектом и его данными на форме это по-сути связь между "Моделью" и "Моделью вида", те самые bindings.

@темы: , события, теория программирования

22:28 

ADO

Настоящий дворянин и программист
Несколько ссылок посвященных технологии ADO.



Вот неплохая статья про ADO для Delphi. В ней доступное вступление о том что такое ADO, MDAC, OLE DB и другие страшные слова: http://www.sql.ru/articles/mssql/2005/122703ado.shtml



А вот вполне приличный справочник по объектам ADO. Незаменимая вещь: http://www.w3schools.com/ado/default.asp



И, конечно, ссылка на infostart. Чтение CSV через ADO: http://infostart.ru/public/98398/

@темы: , ADO, БД

10:45 

IT-Jam

Настоящий дворянин и программист
IT-Jam Kiev September 1st 2012


Все-таки интересно во что превратился IT-Jam за последнее время.
В Харькове, помню, было весело.

@темы: события

10:49 

1C 8.3

Настоящий дворянин и программист
Несколько дней назад вышла ознакомительная версия 1С 8.3

Много интересных изменений. Лично мне больше всего понравилось вот это:


  • реализована выгрузка конфигурации в набор файлов и загрузка из него;

  • теперь для операционной системы Linux созданы клиентские приложения, аналогичные тем, которые существуют для операционной системы Windows (толстый клиент, конфигуратор);

  • данные внешних источников можно помещать во временные таблицы для использования в сложных запросах;


Развернутый отчет об изменениях можно посмотреть на сайте 1С.

@темы: 

16:57 

URL encode/decode online

Настоящий дворянин и программист
Хороший инструмент для сабжа. Поддерживает выбор кодировки.

http://www.url-encode-decode.com/

@темы: ссылка

16:24 

Тестирование RegExp

Настоящий дворянин и программист
За последние несколько месяцев почти прекратил использовать надоевшие конструкции, вроде:


а=Найти(б); Если а>0 Тогда в=Лев(г,а)...



Не, то, чтобы я не знал о RegExp раньше. Еще до 1С активно использовал их в PHP, но в 1С как-то не использовал. Сам даже не знаю почему.



Использовать их не просто, а очень просто, например вот так (запишу, как памятку себе):


    РегЭксп = Новый COMОбъект("VBsсript.RegExp");

РегЭксп.IgnoreCase = Истина;
РегЭксп.Global = Истина;
РегЭксп.MultiLine = Ложь;

РегЭксп.Pattern = "([^0]*)0+(.*)";

Результат = РегЭксп.Replace(Номер, "$1-$2");


Код создания объекта очень простой, а в написании самой сложной части (шаблона) помогают программы тестирования регулярных выражений.

Лично я сейчас пользуюсь Rad Software Regular Expression Designer, так же совсем недавно я встретил интересную публикацию на инфостарт. Там можно скачать обработку 1С, предназначенную для тестирования RegExp.

Есть и платные аналоги.

С инструментом тестирования разработка поискового шаблона превращается в удовольствие.

Используйте RegExp-ы и хорошего вам дня, и хорошего кода.

@темы: regexp, инструменты, ссылка

13:34 

Набросать кода

Настоящий дворянин и программист
Инженер из берлоги поделился интересной ссылкой codepad.org.

Сложно представить практическую пользу от этого инструмента, но образовательная и развлекательная несомненна. Если надо по-быстрому кода "на коленке" набросать, и целый Visual Studio ставить не хочется, то это как-раз для вас.

Поддерживается несколько языков.

@темы: ссылка

19:23 

Scrumboard

Настоящий дворянин и программист
Scrumboard бывает разный...





@темы: scrum, хумор

22:47 

1С:Специалист. Платформа 8.

Настоящий дворянин и программист
Фуф. Сдал.

@темы: , сертификация, текущее

00:31 

А теперь новости кода

Настоящий дворянин и программист
Сегодня в Киеве участниками конференции "Рефакторинг навсегда" был подписан пакт о ненападении на мирно пашущий код.

Основной темой документа стал призыв "работает и не трогай".

В то же время опозиционные силы  развернули масштабную кампанию против гуманного обращения со старым кодом. "Долой спагетти" и "Мы за паттерны", вот какие лозунги сейчас можно услышать на улицах.

Следите за развитием событий.

@темы: хумор

13:33 

Второй параметр в методе "Выбрать". Группировки.

Настоящий дворянин и программист
Сразу хочу предупредить, что вопрос освещаемый в этой статье очень специальный и если вы хотите увидеть общий обзор всего, да с практической пользой и применением, то лучше вам дальше не читать.

Тем же, кого, как и меня, беспокоил не не давал спокойно спать этот мелкий и назойливый вопрос "ну почему список" - добро пожаловать. Итак, интерес исключительно академический, практическая значимость сомнительна. Поехали!

Все началось с того, наш любимый синтакс помощник выдал мне вот такую справку:




РезультатЗапроса (QueryResult)

Выбрать (Choose)



Синтаксис:

Выбрать(<ТипОбхода>, <Группировки>, <ГруппировкиДляЗначенийГруппировок>;)



Параметры:

<ТипОбхода> (необязательный)

Тип: ОбходРезультатаЗапроса.

Задает тип обхода записей в получаемой выборке.

Значение по умолчанию: Прямой



<Группировки> (необязательный)

Тип: Строка.

Список группировок по которым будет вестись обход, разделенных запятыми.

Для детальных записей указывается пустая строка. В случае, если группировки не указаны - будет использоваться следующая группировка, указанная в предложении запроса "ИТОГИ".



<ГруппировкиДляЗначенийГруппировок> (необязательный)

Тип: Строка.

Список группировок, из которых будут выбираться значения группировок для обхода, разделенных запятыми. Если указано "Все", то будут выбираться все значения группировок. Если указана пустая строка, то значения для группировок будут выбираться из предыдущей группировки.



Возвращаемое значение:

Тип: ВыборкаИзРезультатаЗапроса.



Описание:

Формирует выборку записей из результата запроса.



Доступность:

Сервер, толстый клиент, внешнее соединение.



Примечание:

Получение выборок очень большого размера (более 64Mb) требует наличия достаточного количества свободного места на диске, используемом для размещения временных файлов сервера и клиента.



Пример:


Выборка = РезультатЗапроса.Выбрать();


Казалось бы, всё понятно, все пользовались миллион раз. Но, обратите внимание, что в описании второго параметра написано:


Список группировок по которым будет вестись обход, разделенных запятыми.

Исходя из практики сразу скажу, что этот параметр используется редко даже с одной группировкой. Проще в самом запросе указать группировки в нужном порядке, чтобы потом по ним "идти", чем потом в коде пропускать какие-то группировки. Да, и вообще, как уже говорилось - СКД рулит. Но какое-то поведение все-таки закладывалось в метод, когда в параметре перечислен именно список группировок? Какое? Этот вопрос беспокоил не только меня, но интернет предательски молчал.

Вот те мучающиеся вопросом бедолаги, которых мне удалость разыскать (всем привет!):






Ответы однообразны: а зачем тебе это, делай лучше так...



Но мы же договорились, что нами движет академический интерес?

Давайте разберемся что же именно "знает" выборка из результатов запроса и что "знает" выборка из выборки?

Если мы, как обычно, напишем:


Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.Прямой);



То объект "Выборка" будет "знать" (хранить информацию) о всех данных, которые вернул запрос. Заметьте, я специально не опускал первый параметр, хотя по-умолчанию и так подставляется прямой тип обхода. При этом, если в запросе были группировки, то на каждом шаге выборки мы получим разный тип записи запроса (см. метод Выборка.ТипЗаписи) и разный уровень группировок (см. метод Выборка.Уровень).



Если же у нас в запросе есть несколько группировок, например "Склад, Номенклатура, ХарактеристикаНоменклатуры, Регистратор" (ИТОГИ, ну вы помните) и мы представим такую конструкцию:


ВыборкаСклад = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Склад");
Пока
ВыборкаСклад.Следующий() Цикл

   
ВыборкаНоменклатура = ВыборкаСклад.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Номенклатура");
    Пока
ВыборкаНоменклатура.Следующий() Цикл

       
ВыборкаХарактеристикаНоменклатуры = ВыборкаНоменклатура.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "ХарактеристикаНоменклатуры");
        Пока
ВыборкаХарактеристикаНоменклатуры.Следующий() Цикл



        КонецЦикла;

    КонецЦикла;

КонецЦикла;



То объект "ВыборкаСклад" будет знать только о единственном уровне группировок "Склад" и остальные для него значения не имеют. И хотя он позволит опуститься на уровень ниже, но "ВыборкаНоменклатура" это уже другой объект со своим "знанием" для которого, опять-таки, существует единственная группировка - "Номенклатура". Т.е. сам первый параметр определяет будет ли созданный объект обладать информацией о всех уровнях группировки или только об одном. Такие слова как "два уровня"  или "три уровня" тут неуместны.



Жаль, что метод "Выбрать" нельзя "раскрутить" и посмотреть изнутри, было бы любопытно как оно устроено. Но, имеем черный ящик, с чем и живем.



Зато, посмотрите как просто группируются записи по нескольким группировкам, при прямой выборке:


Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.Прямой, "Номенклатура,ХарактеристикаНоменклатуры", ",");



Чем это отличается от выборки без второго и третьего параметров? Только тем, что итоговые записи будут исключительно по указанным группировкам, причем, в итоговой записи "Номенклатура", например, не будет склада, так как по нему не проводилась группировка.

Тут важно отметить одну тонкость. Даже если вы хотите опустить третий параметр метода "Выбрать", количество группировок для значений группировок указать придется, как это сделал я, вставив туда запятую. А вообще правильно было бы сделать, например, так:


Выборка = Результат.Выбрать(ОбходРезультатаЗапроса.Прямой, "Склад,Номенклатура", "Все,Склад");



Итак, подытожу. Бесполезное знание и бестолковый параметр метода. Нет золота в серых горах. Увы. =(



P.S.: Вот переписка с 1С на эту тему, может кого-то занинтересует:



>> В каком случае во втором параметреиспользуется ИМЕННО СПИСОК группировок разделенных запятыми, какое при этом поведение выборки, и нет ли наглядного примера иллюстрирующего такой случай?


<< Список группировок можно применять когда требуется получить группировку выборку по указанным полям.

<< Пример: РезультатЗапроса.Выбрать(ОбходРезультатаЗапроса.Прямой, "Товар,Покупатель", "Все,Товар");


>> Верно ли я понимаю, что использовать список группировок во втором параметре можно _только_ с типом обхода результата запроса "ОбходРезультатаЗапроса.Прямой"?


<< Да, с другими типами обхода при выборке получается только один уровень, поэтому указывать вторую группировку бессмысленно.


Извините.



Публикация на Инфостарт

@темы: 

21:36 

Навигационные ссылки

Настоящий дворянин и программист
Кое-что о навигационных ссылках.



Вот описание из справки 1С, раздел "1С:Предприятие - Встроенный язык - Интерфейс (управляемый) - ПредставлениеНавигационнойСсылки - НавигационнаяСсылка":



  •     Объект информационной базы - e1cib/data/<путь к метаданному>?ref="<идентификатор ссылки>";

  •     Запись регистра информационной базы - e1cib /data/<путь к метаданному>?<имя ключевого поля>="<значение>"[&<имя ключевого поля>="<значение>"];

  •     Реквизит объекта информационной базы - e1cib/data/<путь к метаданному>.<имя реквизита>?ref="<идентификатор ссылки>";

  •     Реквизит табличной части объекта информационной базы - e1cib/data/<путь к метаданному>.<имя табличной части>.<имя реквизита>?ref="<идентификатор ссылки>"index="<индекс строки табличной части>";

  •     Реквизит записи регистра информационной базы - e1cib/data/<путь к метаданному>.<имя реквизита>?<имя ключевого поля>="<значение>" [&<имя ключевого поля>="<значение>"];

  •     Отчет - e1cib/app/<путь к метаданному>;

  •     Обработка - e1cib/app/<путь к метаданному>;

  •     Раздел - e1cib/navigationpoint /<имя раздела>;

  •     Навигационная точка - e1cib/navigationpoint/<имя раздела>/<имя команды>;

  •     Временное хранилище - e1cib/tempstorage/<идентификатор временного значения>.



А в описании к релизу платформы 8.2.15.310 есть вот такое:


Изменен формат навигационных ссылок. Из текста ссылок убраны символы двойных кавычек (”), а значения параметров (после символа “=”) кодируются в соответствии с разделом 2.2. URL Character Encoding Issues стандарта RFC 1738 (с помощью символа “%” и двух шестнадцатеричных символов) для значений измерений регистров сведений и ключей таблиц внешних источников данных. Если измерение регистра сведений имеет составной тип и в значении измерения указывается имя типа, то имя типа также кодируется.

Наконец-то они приводят ссылки в порядок и к RFC.

@темы: 

14:28 

И вовсе не странные. =)))

Настоящий дворянин и программист

Мариша: блин, программисты все такие странные? Муж читает книгу "Совершенный код" и периодически ржёт.

(c) bor

@темы: башорг, хумор

00:38 

Обход запроса по нескольким группировкам

Настоящий дворянин и программист
Хочу поделиться с вами небольшой "зарисовкой", которая помогает мне обходить выборку запроса, как бы пропуская некоторые группировки.

Что я имею в виду. Предположим, у нас есть запрос, который выбирает из регистра движения по номенклатуре в разрезе склада, номенклатуры, характеристики номенклатуры и документа движения. Вот как выглядит "плоская" выгрузка результата этого запроса:





Если в запросе указать итоги по складу, номенклатуре и характеристике номенклатуры и написать следующий код:



то обход будет производиться следующим образом:



Т.е. по первой группировке "Склад" внешний цикл (голубой) совершит одну итерацию, по второй группировке "Номенклатура" ("розовый" цикл) четыре итерации, в каждой из итераций "розового" цикла будет разное количество итераций "зеленого" цикла по группировке "ХарактеристикаНоменклатуры", и в конечном итоге будут выбраны все детальные записи ("серый" цикл), которые на рисунке я отмечать не стал, ибо лениво.



Но иногда хочется выбрать записи вот таким образом:



Т.е. так, чтобы внешний (голубой) цикл выбирал, как и положено, по группировке "Склад", а внутренний (зеленый) выбирал по некой "агрегатной" группировке "Номенклатура+ХарактеристикаНоменклатуры". Ну и дальше по необходимости детальные записи. Это было бы удобно, если бы вы, например, создавали документы по группировке "Склад", а второй "метагруппировкой" заполняли табличную часть каким-либо образом. Конечно, код, который приведен выше, справляется с этой задачей, но лично моя печаль в том, что там есть один вложенный цикл (розовый), который делается совершенно ненужным с точки зрения "изящества кода" как минимум. К тому же, когда таких группировок становится больше, например девять, мы видим совершенно "потрясающую" картину из девяти вложенных циклов.

Еще можно просто пропустить группировку "Номенклатура" и обходить результат запроса по группировкам "Склад - ХарактеристикаНоменклатуры - ДетальныеЗаписи". Но вот беда, в этом случае на уровне характеристики нет самой номенклатуры. Смотрите сами:







Получается, что на уровне выборки по складу номенклатуры еще нет, а на уровне выборки по характеристике ее... все еще нет. Бида.



Я точно знаю, что я не один такой, но у меня и у других коллег по несчастью как-то сам собой напрашивается вот такой код:





Код прекрасен всем, кроме того... что он не работает. Если когда-нибудь разгадаю это тайное послание фирмы 1С о "списке группировок", я обязательно с вами поделюсь. Сейчас же я знаю только то, что этот код мне не удалось заставить работать ни под каким соусом.



Но мы не ждем милости от природы и от 1С. А берем и сами делаем. Вот такой код работает нормально вполне:





Пара слов о функциях.

Функция "зфВыбратьПоГруппировкам" применяется вместо "ВыборкаЛалала.Выбрать()". Ей передается выборка, из которой нужно выбирать, и перечень группировок через запятую. При этом она возвращает некую "метавыборку". Ничего военного, просто соответствие с необходимыми данными.

Функция "зфСледующийПоГруппировкам" применяется вместо "ВыборкаОлоло.Следующий()". Ей передается та самая, открытая на предыдущем шаге "метавыборка" и возвращает она истину или ложь, как и штатный метод "Следующий".

Да. Внутри цикла вы можете смело получать родную 1С-овскую выборку нижнего уровня группировок, обратившись к элементу соответствия "Выборка". Вот так:



РоднаяВыборка1С = МетаВыборка["Выборка"];



Естественно, дальше родную выборку 1С можно хоть снова перебирать этими функциями, хоть выбирать штатными средствами.



Также не могу не сказать, что, в принципе, в функциях нет ничего нового и я тут не претендую на оригинальность или что-нибудь в таком духе. Думаю, что многие писали такие же функции, просто хотелось поделиться с уважаемым сообществом.

Они также не убирают вложенные циклы, просто немного иначе их организуют и скрывают. Т.е. в действительности все "лишние" циклы есть, но из кода это не очевидно.

Еще вполне понятно, что их использование будет менее производительным в смысле быстродействия, нежели использование вороха вложенных циклов. Я, конечно, старался написать пооптимальнее, но сами понимаете, накладные расходы будут.

Да, одна функция рекурсивная. По идее глубина рекурсии будет небольшой и равна количеству пропускаемых группировок плюс один, однако рекурсия есть рекурсия.

Ну и конечно, не исключен вариант, что я где-то накосячил. Если обнаружите - пишите, поправим.



Наконец сами функции:



Функция зфВыбратьПоГруппировкам(Выборка, Группировки, СИерархией = Ложь)

МетаВыборка = Новый Соответствие;

врОбходРезультата = ОбходРезультатаЗапроса.ПоГруппировкам;
Если
СИерархией Тогда
врОбходРезультата = ОбходРезультатаЗапроса.ПоГруппировкамСИерархией;
КонецЕсли;
МетаВыборка.Вставить("ОбходРезультата", врОбходРезультата);

МассивГруппировок = Новый Массив;
врСтрГруппировки = Группировки;
Пока Истина Цикл
Поз = Найти( врСтрГруппировки, "," );
Если
Поз = 0 Тогда
МассивГруппировок.Добавить(СокрЛП(врСтрГруппировки));
Прервать;
КонецЕсли;
МассивГруппировок.Добавить( СокрЛП( Лев(врСтрГруппировки,Поз-1) ) );
врСтрГруппировки = Сред( врСтрГруппировки, Поз+1 );
КонецЦикла;

МетаВыборка.Вставить("Группировки", МассивГруппировок);

врВыборка = Выборка;
Для
пц=0 По МассивГруппировок.Количество()-2 Цикл
врВыборкаУровня = врВыборка.Выбрать(врОбходРезультата, МассивГруппировок[пц]);
МетаВыборка.Вставить("_Выборка"+Строка(пц), врВыборкаУровня);
Если не
врВыборкаУровня.Следующий() Тогда
Прервать;
КонецЕсли;
врВыборка = врВыборкаУровня;
КонецЦикла;
врВыборкаУровня = врВыборка.Выбрать(врОбходРезультата, МассивГруппировок[пц]);
МетаВыборка.Вставить("Выборка", врВыборкаУровня);
МетаВыборка.Вставить("_Выборка"+Строка(пц), врВыборкаУровня);

Возврат
МетаВыборка;

КонецФункции
// зфВыбратьПоГруппировкам

Функция зфСледующийПоГруппировкам(МетаВыборка, Уровень = Неопределено)

Если
Уровень = Неопределено Тогда
Уровень = МетаВыборка["Группировки"].Количество()-1;
КонецЕсли;

Если
Уровень < 0 Тогда
Возврат Ложь;
КонецЕсли;

врВыборка = МетаВыборка["_Выборка"+Строка(Уровень)];

Если
врВыборка.Следующий() Тогда
Возврат Истина;
КонецЕсли;

Если
зфСледующийПоГруппировкам(МетаВыборка, Уровень-1) Тогда
МассивГруппировок = МетаВыборка["Группировки"];
врВыборкаРодитель = МетаВыборка["_Выборка"+Строка(Уровень-1)];
врВыборка = врВыборкаРодитель.Выбрать(МетаВыборка["ОбходРезультата"],МассивГруппировок[Уровень]);
МетаВыборка["_Выборка"+Строка(Уровень)] = врВыборка;
Если
Уровень = МассивГруппировок.Количество()-1 Тогда
МетаВыборка["Выборка"] = врВыборка;
КонецЕсли;
Возврат
зфСледующийПоГруппировкам(МетаВыборка, Уровень);
Иначе
Возврат Ложь;
КонецЕсли;

КонецФункции
// зфСледующийПоГруппировкам


Спасибо за внимание, а я желаю вам хорошего дня и хорошего кода.



Публикация на Инфостарт

@темы: 

20:16 

Паттерн MVVM

Настоящий дворянин и программист
Я давно хожу вокруг паттерна MVVM, но все никак не дойдут руки внимательно за него взяться. И вот, по счастливой случайности Учебный центр Luxoft проводит семинар на эту тему.

Извините, что так поздно сообщаю, сам чуть не пропустил. Регистрируйтесь пока не поздно.

@темы: события

22:17 

Запрос на 90 строк

Настоящий дворянин и программист
Вот цитата с ibash:


ещё один sql-запрос на 90 строк и я попрошу зарплату кокаином

Коллега явно слабак и нуб.

SQL-запрос на 90 строк? Смешно...








@темы: , хумор

22:20 

Почему объектно-ориентированное программирование провалилось?

Настоящий дворянин и программист
Ссылка на интересный обзор с интересными ссылками на классику и классиков.

Итак...

Почему объектно-ориентированное программирование провалилось?

@темы: ООП, ссылка

Green FiLin's blog

главная