• ↓
  • ↑
  • ⇑
 
Записи с темой: конвертация данных (список заголовков)
16:05 

Евгений Гилев, видео КД

Настоящий дворянин и программист
23:39 

КД, обработчики событий и комментарии

Настоящий дворянин и программист
Уже второй раз попадаюсь на теме комментариев в обработчиках событий в ПКО. Причем, второй раз меня туда "попали" типовые правила конвертации из 7.7 в 8.2

В чем суть.

Суть в том, что обработка очень нервно относится к комментариям в обработчиках событий.

В некоторых случаях (в каких именно не тестировал) в обработчиках пропадают переносы строк, а следовательно если где-то внутри конструкции "Если ... Тогда ... КонецЕсли" есть комментарий, то этот самый "КонецЕсли" оказывается закомментированным.

Что очень не нравится обработке загрузки/выгрузки и она вываливается с ошибкой, что-то вроде "не найдено "КонецЕсли". В первый раз это меня поставило в тупик - вроде бы код корректный, а не работает. И уже в отладке выяснилось в чем причина.

Если кому интересно, то в стандартных правилах помощника перехода на 8-ку такой код есть в ПКО "НоменклатураГТД", в событии "ПослеЗагрузки".



Во общем, я бы не советовал использовать в обработчиках комментарии. Во избежание.

@темы: Конвертация данных

Green FiLin's blog

главная